Scheduled for May 10, 2026 at 3:26 PM – 3:39 PM
Affects
Game Panel
Under maintenance from 3:26 PM to 3:39 PM
Completed
May 10, 2026 at 3:39 PMCompleted
May 10, 2026 at 3:39 PMMaintenance has completed successfully.
Update
May 10, 2026 at 3:26 PMUpdate
May 10, 2026 at 3:26 PMMaintenance is now in progress
In progress
May 10, 2026 at 3:26 PMIn progress
May 10, 2026 at 3:26 PMWe're rolling out a backend upgrade to our panel. It might be down for around 30 mins