Planned Maintenance on Game Panel
Scheduled for April 18, 2025 at 9:00 AM – 11:56 AM
Affects
Game Panel
Under maintenance from 9:00 AM to 11:56 AM
Completed
April 18, 2025 at 11:56 AMCompleted
April 18, 2025 at 11:56 AMMaintenance is now complete
In progress
April 18, 2025 at 9:00 AMIn progress
April 18, 2025 at 9:00 AMMaintenance is now in progress.
Planned
April 18, 2025 at 9:00 AMPlanned
April 18, 2025 at 9:00 AMMaintenance will be carried out on the Game Panel. During this time the Game Panel will be inaccessible.
While servers will stay online, but scheduled tasked set to run during the downtime will execute when maintenance is complete.